VCOM:VectorWorks:Workspaces:IWorkspaceFile::CopyPaletteStateInfoFromWorkspace

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceFile

Copies all palette state information from the given Workspace file.

virtual VCOMError VCOM_CALLTYPE CopyPaletteStateInfoFromWorkspace(
IWorkspaceFile* inSourceWorkspaceFile) = 0;

Parameters

inSourceWorkspaceFile IWorkspaceFile* the workspace file to read the palette state info from.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.