VCOM:VectorWorks:Scripting:IVectorScriptEngine::ExecuteScript

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::VectorScript

Member of VCOM:VectorWorks:VectorScript:IVectorScriptEngine

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE ExecuteScript(
const TXString& script) = 0;

Parameters

script const SDK:TXString& Text of the VectorScript to be executed.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

Note that under Vectorworks 2012 this function have limitation on the size of the script. It should be max 3200 characters.