VCOM:VectorWorks:Scripting:IVectorScriptEngine::CompileScript

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::VectorScript

Member of VCOM:VectorWorks:VectorScript:IVectorScriptEngine

This interface provides an method of compiling and accessing dialogs for the purpose of pasting predefined snippets of code.

virtual VCOMErrorVCOM_CALLTYPE CompileScript(
const TXString& script,
bool inShouldDisplayDialogs,
bool& outWasCompiledSuccessfully,
Sint32* outLineNumberOfSelectedError,
TXString* outErrorText) = 0;

Parameters

script const SDK:TXString& This is the script that will be compiled.
inShouldDisplayDialogs bool set this to true in order to display a dialog indicating whether or not the script compilation was successful.
outWasCompiledSuccessfully bool& this is true if the script was compiled successfully.
outLineNumberOfSelectedError Sint32* if there are compile errors, this is the line number of the first found error.
outErrorText SDK:TXString* This is the text describing the error.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.