VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider::FindWidgetIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider

Find the index of the specified widget in this instance's widgets list.

virtual bool FindWidgetIndex(
Sint32 widgetID,
size_t& outIndex) const = 0;

Parameters

widgetID Sint32 widget ID that is to be searched.
outIndex size_t& Output parameter. Return the index to the widget with specified id.

Return Value

Return true if widget with specified ID is found.