VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider::DeleteWidget

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::PluginSupport

Member of VCOM:VectorWorks:PluginSupport:IWidgetsEditProvider

Delete specified widget.

virtual bool DeleteWidget(
size_t index) = 0;

Parameters

index size_t Zero based index to the widget that is to be deleted in the list.

Return Value

Return true if the widget was deleted successfully. False would mean that the index is incorrect.