VCOM:VectorWorks:Math:IPolyDef::InsertVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Math

Member of VCOM:VectorWorks:Math:IPolyDef

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE InsertVertex(
Uint32 index,
const WorldPt3& pt,
EVertexType type) = 0;

Parameters

index Uint32 no info.
pt const SDK:WorldPt3& no info.
type EVertexType no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.