VCOM:VectorWorks:IToolInteractiveDraw::AddNewOrGetExistingObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:IToolInteractiveDraw. Adds a new object with the given id or gets the existing object of the given type and id.

virtual MCObjectHandleVCOM_CALLTYPE AddNewOrGetExistingObject(
MCObjectHandle inObject,
Sint32 id = 0) = 0;

Parameters

inObject MCObjectHandle no info.
id Sint32 no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.