VCOM:VectorWorks:ISDK::SetGradientData

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the spot position, midpoint position and color of the specified gradient segment.

virtual bool SetGradientData(
MCObjectHandle gradient,
short& segmentIndex,
double_param spotPosition,
double_param midpointPosition,
const WorldPt3& color)

Parameters

MCObjectHandle gradient No information available.
short& segmentIndex No information available.
double_param spotPosition No information available.
double_param midpointPosition No information available.
constWorldPt3& color No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009