VCOM:VectorWorks:ISDK::SetCoreWallComponent

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the core wall component of an object.

virtual void VCOM_CALLTYPE SetCoreWallComponent(
MCObjectHandle object,
short coreWallComponent) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
coreWallComponent short The index of the core wall component. 0 will cause there to be no core wall component.

Version

Availability: from Vectorworks 2010