VCOM:VectorWorks:ISDK::RegisterDialogForTimerEvents

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Registers the dialog to receive an event periodically.

virtual boolVCOM_CALLTYPE RegisterDialogForTimerEvents(
long dialogID,
unsigned long numberOfMilliseconds) = 0;

Parameters

dialogID long This id of the dialog that should receive the timed events.
numberOfMilliseconds unsigned long the minimum time delay in between each event.

Version

Availability: from Vectorworks 2010