VCOM:VectorWorks:ISDK::ModifySlab

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Adds to or clips from a slab.

virtual bool VCOM_CALLTYPE ModifySlab(
MCObjectHandle slab,
MCObjectHandle modifier,
bool isClipObject,
Uint32 componentFlags) = 0;

Parameters

slab MCObjectHandle The slab.
modifier MCObjectHandle The adding or clipping object.
isClipObject bool Whether the modifier is an add object or a clip object.
componentFlags Uint32 Bit flags that indicate which components will be affected by the modification.

Return Value

Whether or not the modification succeeds.

Version

Availability: from Vectorworks 2010