VCOM:VectorWorks:ISDK::InsertParameterWidget

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Inserts an existing parameter into the Object Info Palette for event-enabled plug-in objects. position is the 0-based position for this new parameter (subsequent parameters are shifted down); parameterID is the 1-based index of the parameter to insert.

virtual bool InsertParameterWidget(
long ObjectID,
int position,
int parameterID,
const TXString& text,
long data)

Parameters

long ObjectID No information available.
int position No information available.
int parameterID No information available.
const TXString& text No information available.
long data No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009