VCOM:VectorWorks:ISDK::GetObjectStoryBound

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace

Member of VCOM:VectorWorks:ISDK

Get the data of the specified story bound of this object.

virtual boolVCOM_CALLTYPE GetObjectStoryBound(
MCObjectHandle hObject,
TObjectBoundID id,
SStoryObjectData& outData) = 0;

Parameters

hObject MCObjectHandle The object.
id TObjectBoundID The identifier of the story bound.
outData SStoryObjectData& Returns the story bound data.

Return Value

Return TRUE if the operation is successful.

Version

Availability: from Vectorworks 2012