VCOM:VectorWorks:ISDK::GetNamedSubFolderN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Given a parent volume reference, directory ID, & partial pathname, GetNamedSubFolder returns the 'Hard' volume reference & directory ID of the specified folder. It accepts the standard dirID of 2 for the root directory of a volume.

virtual bool GetNamedSubFolderN(
char* parentPath,
const TXString& partialPath,
char outFolderPath[1024])

Parameters

char* parentPath No information available.
constTXString& partialPath No information available.
char outFolderPath[1024] No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009