VCOM:VectorWorks:ISDK::AppendParameterWidget

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Appends an existing parameter onto the Object Info Palette for an event-enabled plug-in object. ParameterID is the 1-based index of the parameter to add; text is the text that will appear on the Object Info Palette for this parameter. data is unused.

virtual bool AppendParameterWidget(
long ObjectID,
int parameterID,
const TXString& text,
long data)

Parameters

long ObjectID No information available.
int parameterID No information available.
constTXString& text No information available.
long data No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009