VCOM:VectorWorks:ISDK::AlertInform: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual void AlertInform( const TXString& text, const TXString& advice = (const unsigned char *)"\0", CBbool minorAlert = false, const TXString& category = (const unsigned char *)"\0",const TXString& item = (const unsigned char *)"\0",const TXString& checkboxOverideText = (const unsigned char *)"\0")
virtual void AlertInform( const TXString& text,  
const TXString& advice = (const unsigned char *)"\0",  
CBbool minorAlert = false,  
const TXString& category = (const unsigned char *)"\0",
const TXString& item = (const unsigned char *)"\0",
const TXString& checkboxOverideText = (const unsigned char *)"\0")
</funcDef>
</funcDef>
</def>
</def>

Latest revision as of 18:50, 5 November 2014

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Displays a dialog which informs the user about the result of a command. Offers no user choices; the user acknowledges the message by clicking the OK button. Specify a category and item to show an optional 'Do not show this this again' checkbox.

virtual void AlertInform(
const TXString& text,
const TXString& advice =)const unsigned char *)"\0",
CBbool minorAlert = false, const TXString& category = (const unsigned char *)"\0", const TXString& item = (const unsigned char *)"\0", const TXString& checkboxOverideText = (const unsigned char *)"\0")

Parameters

constTXString& text No information available.
constTXString&advice=(constunsignedchar * No information available.

Version

Availability: from Vectorworks 2009