VCOM:VectorWorks:Filing:XMLErrors:XMLErrorsDomain

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing::XMLErrors


Contains error codes for XML file structure problems.

namespace XMLErrorsDomain
{
  enum Codes
  {
      NoError                            = 0		// 
      // warnings --------------------------------------------------------------------------------------------------------
    , NotationAlreadyExists              = 2		// Notation '{0}' has already been declared
    , AttListAlreadyExists               = 3		// Attribute '{0}' has already been declared for element '{1}'
    , ContradictoryEncoding              = 4		// Encoding ({0}, from XMLDecl or manually set) contradicts the auto-sensed encoding, ignoring it
    , UndeclaredElemInCM                 = 5		// Element '{0}' was referenced in a content model but never declared
    , UndeclaredElemInAttList            = 6		// Element '{0}' was referenced in an attlist but never declared
    , XMLException_Warning               = 7		// An exception occurred! Type:{0}, Message:{1}
      // errors --------------------------------------------------------------------------------------------------------
    , FeatureUnsupported                 = 10		// {0} is unsupported
    , TopLevelNoNameComplexType          = 11		// Error: Top level complexType has no name - declaration ignored
    , TopLevelNoNameAttribute            = 12		// Globally-declared attribute must have a name - attribute declaration ignored
    , NoNameRefAttribute                 = 13		// Attribute must have a name or a ref - attribute declaration ignored
    , GlobalNoNameElement                = 14		// Globally-declared element must have a name - element declaration ignored
    , NoNameRefElement                   = 15		// Element must have a name or a ref attribute - element ignored
    , NoNameRefGroup                     = 16		// <group> must have a name or a ref attribute - declaration ignored
    , NoNameRefAttGroup                  = 17		// <attributeGroup> must have a name or a ref attribute - declaration ignored
    , AnonComplexTypeWithName            = 18		// Anonymous complexType in element {0} has a name attribute
    , AnonSimpleTypeWithName             = 19		// Anonymous simpleType in element {0} has a name attribute
    , InvalidElementContent              = 20		// The content of an element information item does not match (annotation?, (simpleType | complexType)?, (unique | key | keyref)*)
    , UntypedElement                     = 21		// Untyped element: {0}
    , SimpleTypeContentError             = 22		// Error in content of simpleType
    , ExpectedSimpleTypeInList           = 23		// Expected simpleType in 'list' declaration for {0}
    , ListUnionRestrictionError          = 24		// List | Union | Restriction content is invalid for type {0}
    , SimpleTypeDerivationByListError    = 25		// Error in content of derivation by list for {0}
    , ExpectedSimpleTypeInRestriction    = 26		// Expected simpleType in 'restriction' declaration for {0}
    , DuplicateFacet                     = 27		// Facet {0} already defined - ignoring
    , ExpectedSimpleTypeInUnion          = 28		// Expected simpleType in 'union' declaration for {0}
    , EmptySimpleTypeContent             = 29		// SimpleType content is empty
    , InvalidSimpleContent               = 30		// The content of the simpleContent element is invalid. The content must be RESTRICTION or EXTENSION
    , UnspecifiedBase                    = 31		// The BASE attribute must be specified for the RESTRICTION or EXTENSION element
    , InvalidComplexContent              = 32		// The content of the complexContent element is invalid. The content must be RESTRICTION or EXTENSION
    , SchemaElementContentError          = 33		// Error in content of <schema> element information item
    , ContentError                       = 34		// Content (annotation?,..) is incorrect for type {0}
    , UnknownSimpleType                  = 35		// Unknown simpleType: {0}
    , UnknownComplexType                 = 36		// Unknown complexType: {0}
    , UnresolvedPrefix                   = 37		// Prefix: '{0}' can not be resolved to a URI
    , RefElementNotFound                 = 38		// Ref element {0} not found in the Schema
    , TypeNotFound                       = 39		// Type not found in {0}:{1}
    , TopLevelAttributeNotFound          = 40		// Could not find top level attribute: {0}
    , InvalidChildInComplexType          = 41		// Invalid child '{0}' in the complex type
    , BaseTypeNotFound                   = 42		// Base type could not be found: {0}
    , NoAttributeInSchema                = 43		// No attribute '{0}' was defined in schema: {1}
    , DatatypeValidatorCreationError     = 44		// Error creating datatype validator: {0}
    , InvalidChildFollowingSimpleContent = 45		// Invalid child following the simpleContent child in the complexType
    , InvalidChildFollowingConplexContent= 46	// Invalid child following the complexContent child in the complexType
    , InvalidComplexTypeBlockValue       = 47		// The 'block' attribute values of a complexType must be #all | list(restriction,extension); {0} was found
    , InvalidComplexTypeFinalValue       = 48		// The 'final' attribute values of a complexType must be #all | list(restriction,extension); {0} was found
    , AttributeDefaultFixedValue         = 49		// An attribute cannot have both 'fixed' and 'default' present at the same time - default used
    , NotOptionalDefaultAttValue         = 50		// If default and use are both present, use must have the value 'optional'.
    , LocalAttributeWithNameRef          = 51		// Local attribute:{0} has also a ref defined - name ignored
    , GlobalAttributeWithNameRef         = 52		// Global attribute:'{0}' cannot have a ref defined
    , DuplicateAttribute                 = 53		// Error: Attribute '{0}' declared more than once in the same scope- ignoring
    , AttributeWithTypeAndSimpleType     = 54		// Attribute declarations may not contain both a type and a simpleType declaration
    , AttributeSimpleTypeNotFound        = 55		// SimpleType ({0}:{1}) for attribute: {2} not found
    , ElementWithFixedAndDefault         = 56		// An element cannot have both 'fixed' and 'default' present at the same time
    , DeclarationWithNameRef             = 57		// {0}:'{1}' has also a ref defined - name ignored
    , BadAttWithRef                      = 58		// ref cannot appear with any of type, abstract, block, final, nillable, default or fixed
    , InvalidDeclarationName             = 59		// Invalid {0} name:'{1}' - declaration ignored
    , GlobalElementWithRef               = 60		// Globally-declared element {0} cannot have a ref attribute - ref ignored
    , ElementWithTypeAndAnonType         = 61		// Element '{0}' cannot have both a type attribute and a simpleType/complexType type child
    , NotSimpleOrMixedElement            = 62		// Element {0} has a fixed or default value and must have a mixed simple or simple content model
    , DisallowedSimpleTypeExtension      = 63		// The simpleType {0} that {1} uses has a value of 'final' which does not permit extension
    , InvalidSimpleContentBase           = 64		// The type '{0}' specified as the base in the simpleContent element must not have complexContent
    , InvalidComplexTypeBase             = 65		// The type '{0}' is a simple type. It cannot be used in a derivation by RESTRICTION for a complexType
    , InvalidChildInSimpleContent        = 66		// Invalid child following the RESTRICTION or EXTENSION element in the simpleContent definition
    , InvalidChildInComplexContent       = 67		// Invalid child following the RESTRICTION or EXTENSION element in the complexContent definition
    , AnnotationError                    = 68		// Annotation can only appear once: type {0}
    , DisallowedBaseDerivation           = 69		// The base type {0} does not allow itself to be used as the base for a restriction and/or as a type in a list and/or union
    , SubstitutionRepeated               = 70		// The value 'substitution' already in the list
    , UnionRepeated                      = 71		// The value 'union' is already in the list
    , ExtensionRepeated                  = 72		// The value 'extension' is already in the list
    , ListRepeated                       = 73		// The value 'list' is already in the list
    , RestrictionRepeated                = 74		// The value 'restriction' is already in the list
    , InvalidBlockValue                  = 75		// Invalid block value: {0}
    , InvalidFinalValue                  = 76		// Invalid final value: {0}
    , InvalidSubstitutionGroupElement    = 77		// Element {0} cannot be part of the substitution group headed by {1}
    , SubstitutionGroupTypeMismatch      = 78		// Element {0} has a type which does not derive from the type of the element at the head of the substitution group
    , DuplicateElementDeclaration        = 79		// Duplicate element decl in the same scope: {0}
    , InvalidElementBlockValue           = 80		// The 'block' attribute values of an element must be #all | list(substitution,restriction,extension); {0} was found
    , InvalidElementFinalValue           = 81		// The 'final' attribute values of an element must be #all | list(restriction,extension); {0} was found
    , InvalidAttValue                    = 82		// Invalid value '{0}' for attribute: '{1}'.
    , AttributeRefContentError           = 83		// Ref is present, and simpleType/form/type found
    , DuplicateRefAttribute              = 84		// Duplicate reference attribute {0}:{1} in complexType
    , ForbiddenDerivationByRestriction   = 85		// Derivation by restriction is forbidden by either the base type '{0}' or the schema
    , ForbiddenDerivationByExtension     = 86		// Derivation by extension is forbidden by either the base type '{0}' or the schema
    , BaseNotComplexType                 = 87		// The base type specified in the complexContent element must be a complexType
    , ImportNamespaceDifference          = 88		// Imported schema '{0}' has a different targetNameSpace '{1}' from what's declared '{2}'
    , ImportRootError                    = 89		// Could not get the doc root for imported Schema: {0}
    , DeclarationNoSchemaLocation        = 90		// A schemaLocation attribute must be specified on '{0}' element.
    , IncludeNamespaceDifference         = 91		// Included schema '{0}' has a different targetNameSpace '{1}'
    , OnlyAnnotationExpected             = 92		// At most one <annotation> element is expected in the content.
    , InvalidAttributeContent            = 93		// The content must be (annotation?, simpleType?) for attribute '{0}={1}'
    , AttributeRequired                  = 94		// Attribute '{0}' must appear in {1} {2} declarations
    , AttributeDisallowed                = 95		// Attribute '{0}' cannot appear in {1} {2} declarations
    , InvalidMin2MaxOccurs               = 96		// Value of minOccurs '{0}' must not be greater than value of maxOccurs '{1}'
    , AnyAttributeContentError           = 97		// 'anyAttribute' elements can contain at most one 'annotation' element in their children
    , NoNameGlobalElement                = 98		// Global <{0}> must have a name - declaration ignored
    , NoCircularDefinition               = 99		// No circular definitions are allowed: '{0}'
    , DuplicateGlobalType                = 100		// Global {0}:'{1}' declared more than once or also declared as {2}
    , DuplicateGlobalDeclaration         = 101		// Global {0}:'{1}' declared more than once
    , WS_CollapseExpected                = 102		// Invalid value '{0}' for facet 'whiteSpace'. Value should be 'collapse'.
    , Import_1_1                         = 103		// The namespace of an <import> element must be different from the targetNamespace of the <import>ing schema
    , Import_1_2                         = 104		// If the namespace on an <import> element is not present, the <import>ing schema must have a targetNamespace
    , ElemIDValueConstraint              = 105		// Element '{0}' must not have a value constraint:'{1}' as its type is derived from ID
    , NoNotationType                     = 106		// It is an error for NOTATION to be used directly in a schema in element/attribute '{0}'
    , EmptiableMixedContent              = 107		// For element '{0}', the {content type} is mixed, then the {content type}'s particle must be emptiable
    , EmptyComplexRestrictionDerivation  = 108		// The content of complexType is EMPTY, but base is not empty or does not have emptiable particle.
    , MixedOrElementOnly                 = 109		// The content type of the base type:'{0}' and derived type:'{1}' must both be mixed or element-only.
    , InvalidContentRestriction          = 110		// The content type is not a valid restriction of the content type of the base.
    , ForbiddenDerivation                = 111		// Derivation by extension or restriction is forbidden by either the base type '{0}' or the schema
    , AtomicItemType                     = 112		// The {item type definition} must have {variety} of atomic or union (where all member types must be atomic)
    , MemberTypeNoUnion                  = 113		// The {member type definitions} must all have {variety} of atomic or list
    , GroupContentError                  = 114		// The group:'0' must contain (all | choice | sequence)
    , AttGroupContentError               = 115		// The attributeGroup:'0' must match (annotation?. ((attribute | attributeGroup)*, anyAttribute?))
    , MinMaxOnGroupChild                 = 116		// The child of a model group definition must not specify either the minOccurs or maxOccurs attribute.
    , DeclarationNotFound                = 117		// The {0} -'{1}:{2}'- not found in the schema
    , AllContentLimited                  = 118		// A group whose content is 'all' must only appear as the content type of a complex type definition.
    , BadMinMaxAllCT                     = 119		// When a model group has {compositor} 'all' which constitutes the {content type} of a complex type, minOccurs=maxOccurs=1
    , BadMinMaxAllElem                   = 120		// In an 'all' schema component, the value of minOccurs/maxOccurs of an element must be '0' or '1'.
    , NoCircularAttGroup                 = 121		// Circular attributeGroup reference -{0}- is disallowed outside <redefine>
    , DuplicateAttInDerivation           = 122		// Attribute '{0}' already defined in base and should not appear in derivation by extension.
    , NotExpressibleWildCardIntersection = 123	// The intensional intersection of {attributes wildcard}s must be expressible
    , BadAttDerivation_1                 = 124		// Base type definition does not have any attributes
    , BadAttDerivation_2                 = 125		// Attribute '{0}' has an inconsistent REQUIRED setting with that of the base
    , BadAttDerivation_3                 = 126		// Type of attribute '{0}' must be validly derived from type of attribute in base
    , BadAttDerivation_4                 = 127		// Attribute '{0}' is either not fixed, or has a different value from that of the base
    , BadAttDerivation_5                 = 128		// Attribute '{0}' has invalid target namespace with respect to a base wildcard constraint or, base has no wildcard
    , BadAttDerivation_6                 = 129		// An attribute wildcard is present in the derived type, but not in the base
    , BadAttDerivation_7                 = 130		// The attribute wildcard in the derived type is not a valid subset of that in the base
    , BadAttDerivation_8                 = 131		// Attribute '{0}' cannot modify the 'use' attribute in a derived type, if base attribute use is prohibited
    , BadAttDerivation_9                 = 132		// The wildcard attribute in the derived type must be identical to or stronger than the one in the base.
    , AllContentError                    = 133		// Content of <all> is restricted to elements only. '{0}' encountered and ignored.
    , RedefineNamespaceDifference        = 134		// Redefined schema '{0}' has a different targetNameSpace '{1}'.
    , Redefine_InvalidSimpleType         = 135		// A simpleType child of a <redefine> must have a restriction element as a child
    , Redefine_InvalidSimpleTypeBase     = 136		// The base attribute of the restriction child of a simpleType, must be the same as the redefine simpleType's name attribute
    , Redefine_InvalidComplexType        = 137		// A complexType child of a <redefine> must have a restriction or extension element as a grandchild
    , Redefine_InvalidComplexTypeBase    = 138		// The base attribute of a restriction/extension must be the same as the complexType's name attribute in <redefine>
    , Redefine_InvalidGroupMinMax        = 139		// The group '{0}' which contains a reference to a group being redefined must have minOccurs = maxOccurs = 1
    , Redefine_DeclarationNotFound       = 140		// Could not find a declaration in the schema to be redefined corresponding to '{0}'
    , Redefine_GroupRefCount             = 141		// If a group child of a <redefine> element contains a group ref'ing itself, it must have exactly 1 reference.
    , Redefine_AttGroupRefCount          = 142		// If an attributeGroup of a <redefine> element contains a reference to itself, such reference must be exactly 1
    , Redefine_InvalidChild              = 143		// A <redefine> element cannot contain a child of type '{0}'
    , Notation_InvalidDecl               = 144		// The declaration for notation '{0}' is invalid
    , Notation_DeclNotFound              = 145		// The notation declaration '{0}:{1}' is not found
    , IC_DuplicateDecl                   = 146		// More than one identity constraint named '{0}'.
    , IC_BadContent                      = 147		// The content of an identity constraint must match (annotation?, selector, field+)
    , IC_KeyRefReferNotFound             = 148		// Key reference declaration '{0}' refers to unknown key with name '{1}'.
    , IC_KeyRefCardinality               = 149		// Cardinality of fields for keyref '{0}' and key '{1}' must match.
    , IC_XPathExprMissing                = 150		// Xpath expression is either missing or empty
    , AttUseCorrect                      = 151		// The {value constraint} of an attribute ref is not fixed or different from the fixed {value constraint} of '{0}'
    , AttDeclPropCorrect3                = 152		// The {type definition} for attribute '{0}={1}' is or is derived from ID, and must not have {value constraint}
    , AttDeclPropCorrect5                = 153		// More than one attribute derived from type ID cannot appear in the same complex type - '{0}' ignored
    , AttGrpPropCorrect3                 = 154		// More than one attribute derived from type ID cannot appear in the same attribute group - '{0}' ignored
    , InvalidTargetNSValue               = 155		// '' is not a legal value for the targetNamespace attribute; the attribute must be absent or contain a nonempty value
    , DisplayErrorMessage                = 156		// {0}
    , XMLException_Error                 = 157		// An exception occurred! Type:{0}, Message:{1}
    , InvalidRedefine                    = 158		// Invalid Redefine: '{0}' has already been included or redefined
    , InvalidNSReference                 = 159		// Schema Representation Constraint: Namespace '{0}' is referenced without <import> declaration
    , NotAllContent                      = 160		// An 'all' model group that's part of a complex type definition must constitute the entire content type of the definition
    , InvalidAnnotationContent           = 161		// An <annotation> can only contain <appinfo> and <documentation> elements
    , InvalidFacetName                   = 162		// Invalid facet name: {0}
    , InvalidXMLSchemaRoot               = 163		// The root element name of an XML Schema should be 'schema'.
    , CircularSubsGroup                  = 164		// Circular substitution groups are disallowed for element '{0}'.
    , SubsGroupMemberAbstract            = 165		// For '{0}' to be a member of the substitution group set of '{1}', its {abstract} must be false.
    , ELTSchemaNS                        = 166		// The namespace of element '{0}' must be from the schema namespace.
    , InvalidAttTNS                      = 167		// The {target namespace} of '{0}' must not match 'http://www.w3.org/2001/XMLSchema-instance'.
    , NSDeclInvalid                      = 168		// The namespace declaration is invalid.
    , DOMLevel1Node                      = 169		// Namespace fixup cannot be performed on a DOM Level 1 Node.
      // warnings --------------------------------------------------------------------------------------------------------
    , EntityExpansionLimitExceeded       = 172		// The parser has encountered more than '{0}' entity expansions in this document; this is the limit imposed by the application.
    , ExpectedCommentOrCDATA             = 173		// Expected comment or CDATA
    , ExpectedAttrName                   = 174		// Expected an attribute name
    , ExpectedNotationName               = 175		// Expected a notation name
    , NoRepInMixed                       = 176		// Repetition of individual elements is not legal for mixed content models
    , BadDefAttrDecl                     = 177		// Bad default attribute declaration
    , ExpectedDefAttrDecl                = 178		// Expected default attribute declaration, assuming #IMPLIED 
    , AttListSyntaxError                 = 179		// Attribute list syntax error
    , ExpectedEqSign                     = 180		// Expected equal sign
    , DupAttrName                        = 181		// Duplication attribute name
    , BadIdForXMLLangAttr                = 182		// Bad ID, '{0}', for xml:lang attribute
    , ExpectedElementName                = 183		// Expected an element name
    , MustStartWithXMLDecl               = 184		// Must start with an XMLDecl
    , CommentsMustStartWith              = 185		// Comments must start with <!--
    , InvalidDocumentStructure           = 186		// Invalid document structure
    , ExpectedDeclString                 = 187		// Expected a 'version=', 'encoding=', or 'standalone='
    , BadXMLVersion                      = 188		// Bad XML version string
    , UnsupportedXMLVersion              = 189		// Unsupported XML version, '{0}'
    , UnterminatedXMLDecl                = 190		// Unterminated XML decl
    , BadXMLEncoding                     = 191		// Bad XML encoding declaration, '{0}'
    , BadStandalone                      = 192		// Bad standalone declaration
    , UnterminatedComment                = 193		// Unterminated comment
    , PINameExpected                     = 194		// Processing instruction name expected
    , UnterminatedPI                     = 195		// Unterminated processing instruction
    , InvalidCharacter                   = 196		// Invalid character (Unicode: 0x{0})
    , UnexpectedTextBeforeRoot           = 197		// Unexpected text before root element
    , UnterminatedStartTag               = 198		// Unterminated start tag, '{0}'
    , ExpectedAttrValue                  = 199		// Expected an attribute value
    , UnterminatedEndTag                 = 200		// Unterminated end tag
    , ExpectedAttributeType              = 201		// Expected type (CDATA, ID, NMTOKEN, ..), for attribute '{0}' of element '{1}'
    , ExpectedEndOfTagX                  = 202		// Expected end of tag '{0}'
    , ExpectedMarkup                     = 203		// Expected tag name, comment, PI, or other markup
    , NotValidAfterContent               = 204		// Not valid after content
    , ExpectedComment                    = 205		// Expected comment
    , ExpectedCommentOrPI                = 206		// Expected comment or processing instruction
    , ExpectedWhitespace                 = 207		// Expected whitespace
    , NoRootElemInDOCTYPE                = 208		// No root element in DOCTYPE
    , ExpectedQuotedString               = 209		// Expected quoted string
    , ExpectedPublicId                   = 210		// Expected public id
    , InvalidPublicIdChar                = 211		// Invalid character in public id (Unicode: 0x{0})
    , UnterminatedDOCTYPE                = 212		// Unterminated DOCTYPE declaration
    , InvalidCharacterInIntSubset        = 213		// Invalid character in internal subset (Unicode: 0x{0})
    , ExpectedCDATA                      = 214		// Expected CDATA section
    , InvalidInitialNameChar             = 215		// Invalid initial name character
    , InvalidNameChar                    = 216		// Invalid name character
    , UnexpectedWhitespace               = 217		// Unexpected whitespace
    , InvalidCharacterInAttrValue        = 218		// Invalid character in attribute value {0} (Unicode: 0x{1})
    , ExpectedMarkupDecl                 = 219		// Expected a markup declaration
    , TextDeclNotLegalHere               = 220		// Text declaration not legal here
    , ConditionalSectInIntSubset         = 221		// Conditional section in internal subset
    , ExpectedPEName                     = 222		// Expected parameter entity name
    , UnterminatedEntityDecl             = 223		// Unterminated entity declaration, '{0}'
    , InvalidCharacterRef                = 224		// Invalid character reference
    , UnterminatedCharRef                = 225		// Unterminated character reference
    , ExpectedEntityRefName              = 226		// Expected entity name for reference
    , EntityNotFound                     = 227		// Entity '{0}' was not found
    , NoUnparsedEntityRefs               = 228		// Unparsed entity references, '{0}', not valid here
    , UnterminatedEntityRef              = 229		// Unterminated entity reference
    , RecursiveEntity                    = 230		// Recursive entity expansion
    , PartialMarkupInEntity              = 231		// Partial markup in entity value
    , UnterminatedElementDecl            = 232		// Unterminated element declaration, '{0}'
    , ExpectedContentSpecExpr            = 233		// Expected content specification expression for element '{0}'
    , ExpectedAsterisk                   = 234		// Expected asterisk
    , UnterminatedContentModel           = 235		// Unterminated Content model
    , ExpectedSystemId                   = 236		// Expected system id
    , ExpectedSystemOrPublicId           = 237		// Expected system or public id
    , UnterminatedNotationDecl           = 238		// Unterminated notation declaration
    , ExpectedSeqChoiceLeaf              = 239		// Expected ',', '|', or ')' characters
    , ExpectedChoiceOrCloseParen         = 240		// Expected '|' or ')' characters
    , ExpectedSeqOrCloseParen            = 241		// Expected ',' or ')' characters or close parenthesis in content model of element '{0}'
    , ExpectedEnumValue                  = 242		// Expected enumeration value for attribute '{0}'
    , ExpectedEnumSepOrParen             = 243		// Expected | enumeration separator, or closing paren
    , UnterminatedEntityLiteral          = 244		// Unterminated entity literal
    , MoreEndThanStartTags               = 245		// There are more end tags than start tags
    , ExpectedOpenParen                  = 246		// Expected an open parenthesis
    , AttrAlreadyUsedInSTag              = 247		// The attribute '{0}' is already used in element '{1}'
    , BracketInAttrValue                 = 248		// A '<' character cannot be used in attribute '{0}', except through <
    , Expected2ndSurrogateChar           = 249		// A leading surrogate character was not followed by a legal second character
    , ExpectedEndOfConditional           = 250		// Expected ']]>' to end a conditional section
    , ExpectedIncOrIgn                   = 251		// Expected INCLUDE or IGNORE here
    , ExpectedINCLUDEBracket             = 252		// Expected [ to follow INCLUDE or IGNORE
    , ExpectedTextDecl                   = 253		// Expected a TextDecl here: <?xml ....
    , ExpectedXMLDecl                    = 254		// Expected a XMLDecl here: <?xml ....
    , UnexpectedEOE                      = 255		// Unexpected end of entity {0}
    , PEPropogated                       = 256		// A PE propagated out of the int/ext subset, discarding extra text
    , ExtraCloseSquare                   = 257		// An extra ] character was found an ignored
    , PERefInMarkupInIntSubset           = 258		// PE refs are not allowed inside markup in the internal subset
    , EntityPropogated                   = 259		// An entity propagated out of the content section into Miscellaneous
    , ExpectedNumericalCharRef           = 260		// Expected &# to be followed by a numeric character value
    , ExpectedOpenSquareBracket          = 261		// Expected an open bracket ('[') here
    , BadSequenceInCharData              = 262		// The sequence ']]>' is not allowed in character data
    , IllegalSequenceInComment           = 263		// Illegal sequence '--' in comment
    , UnterminatedCDATASection           = 264		// Unterminated CDATA section
    , ExpectedNDATA                      = 265		// Expected NDATA
    , NDATANotValidForPE                 = 266		// NDATA is not legal for parameter entities
    , HexRadixMustBeLowerCase            = 267		// Hex radix character refs must use 'x', not 'X'
    , DeclStringRep                      = 268		// '{0}' has already been set. Ignoring redundant setting
    , DeclStringsInWrongOrder            = 269		// The XMLDecl strings must be in the order: version, encoding, standalone
    , NoExtRefsInAttValue                = 270		// External entities cannot be referred to from attribute values
    , XMLDeclMustBeLowerCase             = 271		// The XML or Text decl must start with '<?xml ', not '<?XML '
    , ExpectedEntityValue                = 272		// Expected a literal entity value or PUBLIC/SYSTEM id
    , BadDigitForRadix                   = 273		// '{0}' is not a valid digit for the indicated radix
    , EndedWithTagsOnStack               = 274		// The input ended before all started tags were ended. Last tag started was '{0}'
    , AmbiguousContentModel              = 275		// The content model for element '{0}' is ambiguous
    , NestedCDATA                        = 276		// Nested CDATA sections are not allowed
    , UnknownPrefix                      = 277		// The prefix '{0}' has not been mapped to any URI
    , PartialTagMarkupError              = 278		// The start and the end tag were in the different entities
    , EmptyMainEntity                    = 279		// The main XML document cannot be empty
    , CDATAOutsideOfContent              = 280		// CDATA is not allowed outside the root element
    , OnlyCharRefsAllowedHere            = 281		// Only numeric character entities or special character entities are legal here
    , Unexpected2ndSurrogateChar         = 282		// Got an unexpected trailing surrogate character
    , NoPIStartsWithXML                  = 283		// No processing instruction starts with 'xml'
    , XMLDeclMustBeFirst                 = 284		// The XML or Text declaration must start at line/column 1/1
    , XMLVersionRequired                 = 285		// The 'version=' string is required in an XMLDecl
    , StandaloneNotLegal                 = 286		// The 'standalone=' string is only allowed in the main XML entity
    , EncodingRequired                   = 287		// The 'encoding=' string is required in an Text Decl
    , TooManyColonsInName                = 288		// When namespaces are enabled, a name can have only one colon character
    , InvalidColonPos                    = 289		// When namespaces are enabled, the colon cannot be the first or last character
    , ColonNotLegalWithNS                = 290		// Colons are not allowed in this name when namespaces are enabled
    , SysException                       = 291		// A system exception occurred during processing
    , XMLException_Fatal                 = 292		// An exception occurred! Type:{0}, Message:{1}
    , UnexpectedEOF                      = 293		// Unexpected end of file exception. Message: {0}
    , UnexpectedError                    = 294		// UnexpectedError
    , BadSchemaLocation                  = 295		// The schemaLocation attribute does not contain pairs of values.
    , NoGrammarResolver                  = 296		// Internal error: don't have a GrammarResolver for TraverseSchema
    , SchemaScanFatalError               = 297		// Fatal error encountered during schema scan
    , IllegalRefInStandalone             = 298		// Reference to external entity declaration '{0}' is not allowed in a standalone document.
    , PEBetweenDecl                      = 299		// Partial markup in parameter entity replacement text in a complete declaration.
    , NoEmptyStrNamespace                = 300		// The value of the attribute '{0}' is invalid. Prefixed namespace bindings may not be empty.
    , NoUseOfxmlnsAsPrefix               = 301		// The prefix 'xmlns' cannot be bound to any namespace explicitly.
    , NoUseOfxmlnsURI                    = 302		// The namespace for 'xmlns' cannot be bound to any prefix explicitly.
    , PrefixXMLNotMatchXMLURI            = 303		// The prefix 'xml' cannot be bound to any namespace other than its usual namespace.
    , XMLURINotMatchXMLPrefix            = 304		// The namespace for 'xml' cannot be bound to any prefix other than 'xml'.
    , NoXMLNSAsElementPrefix             = 305		// Element '{0}' cannot have 'xmlns' as its prefix.
    , CT_SimpleTypeChildRequired         = 306		// Complex Type Definition Representation OK - 2.2: <restriction> must have a <simpleType> child.
  };
}

Remarks

See remarsk of IXMLFileValidator::SetErrorListener

Some error descriptions contain '{0}', '{1}', '{2}' or '{3}'. On this place of the error text (IXMLFileValidatorErrorListener::fDescription) that is reported represents dynamic text reported by IXMLFileValidatorErrorListener::fText1, IXMLFileValidatorErrorListener::fText2, IXMLFileValidatorErrorListener::fText3, or IXMLFileValidatorErrorListener::fText4

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFile | VCOM:VectorWorks:Filing:IXMLFileValidator | VCOM:VectorWorks:Filing:XMLErrors

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFile]] | [[VCOM:VectorWorks:Filing:IXMLFileValidator]] | [[VCOM:VectorWorks:Filing:XMLErrors]]