VCOM:VectorWorks:Filing:IXMLFileNode::GetParentNode

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IXMLFileNode

Retrieve the parent node of this node instance.

The funtion will fail if this node instance is the root.

virtual VCOMError VCOM_CALLTYPE GetParentNode(
IXMLFileNode** ppOutNode) = 0;

Parameters

ppOutNode IXMLFileNode** Output parameter. Returns instance of the parent node. </line>

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFileNode | VCOM:VectorWorks:Filing:IXMLFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFileNode]] | [[VCOM:VectorWorks:Filing:IXMLFile]]