VCOM:VectorWorks:Filing:IXMLFileNode::GetNodeAttributeValue

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IXMLFileNode

Retreives the specified attribute value. The attribute is represented by it's name.

virtual VCOMError VCOM_CALLTYPE GetNodeAttributeValue(
const TXString& attrName,
TXString& outValue) = 0;

Parameters

attrName const TXString& Specify the attributes name which value is to be returned.
outValue TXString& Output parameter. Return the attributes value.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

XML attribute is:

<nodeName attrName="attrValue"> 
nodeValue 
</nodeName>

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFileNode | VCOM:VectorWorks:Filing:IXMLFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFileNode]] | [[VCOM:VectorWorks:Filing:IXMLFile]]