VCOM:VectorWorks:Filing:IXMLFileNode::CreateChildNode

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IXMLFileNode

Create child in this node instance with specified name.

New node instance is returned.

virtual VCOMError VCOM_CALLTYPE CreateChildNode(
const TXString& name,
IXMLFileNode** ppOutNode) = 0;

Parameters

name const TXString& The name of the new child.
ppOutNode IXMLFileNode** Output parameter. Instance of the new child.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Remarks

The XML allows to have may childs with the same name inside single XML node.

Example

// the new child is an empty VCOM instance
// the CreateChildNode call queries instance for the new child
IXMLFileNode pNewChild;
pThisNode->CreateChildNode( "nodeName", & pNewChild );

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFileNode | VCOM:VectorWorks:Filing:IXMLFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFileNode]] | [[VCOM:VectorWorks:Filing:IXMLFile]]