VCOM:VectorWorks:Filing:IStdFile::WriteNewLineUni: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(3 intermediate revisions by the same user not shown)
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Filing:IStdFile]]
Member of [[VCOM:VectorWorks:Filing:IStdFile]]


...put some description here...
Write a new line in UTF-16 Unicode.
</desc>
</desc>


Line 16: Line 16:
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE WriteNewLineUni() = 0;
virtual VCOMErrorVCOM_CALLTYPE WriteNewLineUni() = 0;
</funcDef>
<funcDef lang="cpp">
virtual VCOMError VCOM_CALLTYPE WriteNewLineUni(ELineEndType type) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 22: Line 25:
<params>
<params>
<lineList ident=1>
<lineList ident=1>
<line>
type
ELineEndType
Type of the new line symbol to be written. See [[VCOM:VectorWorks:Filing:IStdFile::SetDefaultNewLine|IStdFile::SetDefaultNewLine]] for details on this enumeration.
</line>
</lineList>
</lineList>
</params>
</params>

Latest revision as of 17:51, 19 September 2013

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Write a new line in UTF-16 Unicode.

virtual VCOMErrorVCOM_CALLTYPE WriteNewLineUni( ) = 0;
virtual VCOMError VCOM_CALLTYPE WriteNewLineUni(
ELineEndType type) = 0;

Parameters

type ELineEndType Type of the new line symbol to be written. See IStdFile::SetDefaultNewLine for details on this enumeration.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014