VCOM:VectorWorks:Filing:IPathResolver::Resolve

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IPathResolver

Resolved specified link to file or folder.

virtual VCOMErrorVCOM_CALLTYPE Resolve(
IFileIdentifier* pInOutFileIdentifier) = 0;
virtual VCOMErrorVCOM_CALLTYPE Resolve(
IFolderIdentifier* pInOutFolderIdentifier) = 0;

Parameters

pInOutFileIdentifier IFileIdentifier* File identifier to a link file that is to be resolved. The file ID is modified to point to the resolved file.
pInOutFileIdentifier IFolderIdentifier* File identifier to a link folder that is to be resolved. The file ID is modified to point to the resolved folder.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]]