VCOM:VectorWorks:Extension:ISendToSurfaceProvider::SendToSurface

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:ISendToSurfaceProvider

...put some description here...

virtual VCOMErrorVCOM_CALLTYPE SendToSurface(
MCObjectHandle hObject,
MCObjectHandle hDTMObject,
ETINType tinType,
TSendToSurfaceContextMap& mapContext) = 0;

Parameters

hObject MCObjectHandle no info.
hDTMObject MCObjectHandle no info.
tinType ETINType no info.
mapContext TSendToSurfaceContextMap& no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.