VCOM:VectorWorks:Extension:IDTMTIN::RisePolygon

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Rise polygon to the Site model surface. In other words, update the Z coordinates of the polygon vertices and insert extra vertices to the polygon (if necessary) so the resulting polygon lies on the Site model surface.

virtual VCOMErrorVCOM_CALLTYPE RisePolygon(
IPolyDef* poly) = 0;

Parameters

poly IPolyDef* Input and output parameter. The polygon.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.