VCOM:VectorWorks:Extension:IDTMTIN::GetVisibleContourPolygonAt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]


...put some description here...
Gets the contour 2D polygon and the contour elevation in document coordinates.
Depending on the Site model's settings gets the contour polygon or the smoothed contour polygon.
</desc>
</desc>


Line 25: Line 26:
contourIndex
contourIndex
size_t
size_t
no info.
index of contour.
</line>
</line>
<line>
<line>
pOutContourPoly2D
pOutContourPoly2D
IPolyDef*
IPolyDef*
no info.
result contour poly.
</line>
</line>
<line>
<line>
outContourElevation
outContourElevation
double&
double&
no info.
result contour elevation.
</line>
</line>
</lineList>
</lineList>

Revision as of 07:49, 17 October 2013

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Gets the contour 2D polygon and the contour elevation in document coordinates. Depending on the Site model's settings gets the contour polygon or the smoothed contour polygon.

virtual VCOMErrorVCOM_CALLTYPE GetVisibleContourPolygonAt(
size_t contourIndex,
IPolyDef* pOutContourPoly2D,
double& outContourElevation) = 0;

Parameters

contourIndex size_t index of contour.
pOutContourPoly2D IPolyDef* result contour poly.
outContourElevation double& result contour elevation.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.