VCOM:VectorWorks:Extension:IDTMTIN::GetVisibleContourPolygonAt

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Gets the contour 2D polygon and the contour elevation in document coordinates. Depending on the Site model's settings gets the contour polygon or the smoothed contour polygon.

virtual VCOMErrorVCOM_CALLTYPE GetVisibleContourPolygonAt(
size_t contourIndex,
IPolyDef* pOutContourPoly2D,
double& outContourElevation) = 0;

Parameters

contourIndex size_t index of contour.
pOutContourPoly2D IPolyDef* resulting contour poly.
outContourElevation double& resulting contour elevation.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.