VCOM:VectorWorks:Extension:IDTMTIN::GetLabels: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]
Member of [[VCOM:VectorWorks:Extension:IDTMTIN]]


...put some description here...
Gets the Site model's labels. The labels positions are returned in document coordinates.
</desc>
</desc>


Line 25: Line 25:
outArrLabels
outArrLabels
STINLabel*
STINLabel*
no info.
resulting labels.
</line>
</line>
<line>
<line>
inOutCount
inOutCount
size_t&
size_t&
no info.
input: maximum count of returned labels, output: count of returned labels.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 08:00, 17 October 2013

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Gets the Site model's labels. The labels positions are returned in document coordinates.

virtual VCOMErrorVCOM_CALLTYPE GetLabels(
STINLabel* outArrLabels,
size_t& inOutCount) = 0;

Parameters

outArrLabels STINLabel* resulting labels.
inOutCount size_t& input: maximum count of returned labels, output: count of returned labels.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.