VCOM:VectorWorks:Extension:IDTMTIN::GetLabels

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Gets the Site model's labels. The labels positions are returned in document coordinates.

virtual VCOMErrorVCOM_CALLTYPE GetLabels(
STINLabel* outArrLabels,
size_t& inOutCount) = 0;

Parameters

outArrLabels STINLabel* resulting labels.
inOutCount size_t& input: maximum count of returned labels, output: count of returned labels.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.