VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette::GetTearOffState: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceToolPalette

Gets the status flag that indicates whether or not this is a tear-off tool palette.

virtual VCOMError VCOM_CALLTYPE GetTearOffState(
bool& outTearOffState) = 0;

Parameters

outTearOffState bool& on output, if successful, a bool indicating whether this tool palette is a tear-off or not.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.