VCOM:VectorWorks:Filing:IStdFile::WriteNewLineUni

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Write a new line in UTF-16 Unicode.

virtual VCOMErrorVCOM_CALLTYPE WriteNewLineUni( ) = 0;
virtual VCOMError VCOM_CALLTYPE WriteNewLineUni(
ELineEndType type) = 0;

Parameters

type ELineEndType Type of the new line symbol to be written. See IStdFile::SetDefaultNewLine for details on this enumeration.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014