VCOM:VectorWorks:Filing:IStdFile::WriteNewLine
Jump to navigation
Jump to search
.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference
Description
namespace VectorWorks::Filing
Member of VCOM:VectorWorks:Filing:IStdFile
Writes a new line into the current file read/write position.
Either writes the default line ending or let's you specify the type of the line ending. See: IStdFile::SetDefaultNewLine
virtual VCOMError VCOM_CALLTYPE WriteNewLine( ) = 0;
virtual VCOMError VCOM_CALLTYPE WriteNewLine(
ELineEndType type) = 0;
Parameters
type ELineEndType The line ending that is to be written. See: IStdFile::SetDefaultNewLine
Return Value
Uses standard VCOM Error Reporting.
Return value meaning:
kVCOMError_NotInitialized Bad VCOM instance used to call the fuction. kVCOMError_Failed Routine failed.
See Also
VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile
[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]