VCOM:VectorWorks:Filing:IStdFile::OpenRead

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing

Member of VCOM:VectorWorks:Filing:IStdFile

Open a file for reading.

virtual VCOMError VCOM_CALLTYPE OpenRead(
IFileIdentifier* pFileID,
bool bRandomAccess) = 0;

Parameters

pFileID VCOM:VectorWorks:Filing:IFileIdentifier|IFileIdentifier]]* File identifier for the file that is to be opened.
bRandomAccess bool true if the instance should support random access to the file; false if it will be read from top to bottom.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

See Also

VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile

[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]