VS:ZCenterN

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the z-coordinate value of the center of the bounding box of an object matching the search criteria. If more than one object matches the search criteria, the function will return the z-coordinate of the average center point of all the matching objects

FUNCTION ZCenterN(
c :CRITERIA) : REAL;
def vs.ZCenterN(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

ZCenValue:=ZCenterN(N='Board');
{returns the z-coord of the center of the bounding box of the named object 'Board'

Version

Availability: from Vectorworks 2012