VS:UpdateSymbolDisplayControl/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

シンボルを表示するコントロールを更新します。 空白のコントロールを表示するには、シンボル名を空にしてください。

PROCEDURE UpdateSymbolDisplayControl(
dialogID :LONGINT;
itemID :LONGINT;
symbolName :STRING;
renderMode :INTEGER;
view :INTEGER);
def vs.UpdateSymbolDisplayControl(dialogID, itemID, symbolName, renderMode, view):
    return None

Parameters

dialogID LONGINT ダイアログ番号
itemID LONGINT アイテム番号
symbolName STRING シンボル名
renderMode INTEGER レンダリングモード
view INTEGER 視点

Example

CreateSymbolDisplayControl( 5, 6, 'Chair', 350, 200, 5, 11, 9 );
{Other code}
UpdateSymbolDisplayControl( 5, 6, 'Chair', 0, 3 );

This creates a dialog control that displays the symbol called "Chair."  The control is 350 pixels high and 200 pixels wide, with a margin of 5 pixels.  The symbol is rendered in OpenGL mode and displayed in a right isometric view.  It then later updates the control to display the same symbol rendered in Wireframe in a front view.

Version

利用可能バージョン: VectorWorks12.0

See Also

関連関数:

VS:CreateSymbolDisplayControl

関連関数: [[VS:CreateSymbolDisplayControl]]