VS:SetPrefString

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the value of the specified VectorWorks preference setting. Used with preference settings requiring a STRING value.

A table of preference dialog items and their corresponding IDs may be found in the Appendix.

PROCEDURE SetPrefString(
index :INTEGER;
value :STRING);
def vs.SetPrefString(index, value):
    return None

Parameters

index INTEGER Preference item index.
value STRING New value for preference.

Remarks

Sets the value of the specified preference to the value passed. Similar to SetPref() except it works on preferences for string values

Example

VectorScript

SetPrefString(154,'cubits');

Python


Version

Availability: from VectorWorks9.0