VS:SetLBItemReadOnly

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the item's read-only state.

PROCEDURE SetLBItemReadOnly(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
readOnly :BOOLEAN);
def vs.SetLBItemReadOnly(dialogID, componentID, itemIndex, subItemIndex, readOnly):
    return None

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
readOnly BOOLEAN the read-only state

Version

Availability: from Vectorworks 2022