VS:GetSymLoc3D

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines the location of a specified symbol or plug-in object in 3D space.

PROCEDURE GetSymLoc3D(
objectHandle :HANDLE;
VAR x :REAL;
VAR y :REAL;
VAR z :REAL);
def vs.GetSymLoc3D(objectHandle):
    return (x, y, z)

Parameters

objectHandle HANDLE Handle to a symbol instance or a plug-in object in the drawing.
x REAL The location of the object along the x-axis.
y REAL The location of the object along the y-axis.
z REAL The location of the object along the z-axis.

Version

Availability: from VectorWorks10.0