VS:GetPolyBreakGeometry

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

If the break, in theWall at the specified break index, references a polyBreak object then a copy of the polybreak is converted into a polyline object.

PROCEDURE GetPolyBreakGeometry(
theWall :HANDLE;
breakIndex :INTEGER;
VAR polyline :HANDLE);
def vs.GetPolyBreakGeometry(theWall, breakIndex):
    return polyline

Parameters

theWall HANDLE
breakIndex INTEGER
polyline HANDLE

Remarks

The Caller is responsible for deleting the returned polyline (use GS_DeleteObject w/ undo = false)

Version

Availability: from VectorWorks10.0