VS:GetFillPoints/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

原点やI、J軸の終点座標を返します。


注:グラデーションやイメージ属性をもつ2次元図形でのみ利用できます。

PROCEDURE GetFillPoints(
objectHandle :HANDLE;
VAR xOriginPoint :REAL;
VAR yOriginPoint :REAL;
VAR xIAxisEndPoint :REAL;
VAR yIAxisEndPoint :REAL;
VAR xJAxisEndPoint :REAL;
VAR yJAxisEndPoint :REAL);
def vs.GetFillPoints(objectHandle):
    return (xOriginPoint, yOriginPoint, xIAxisEndPoint, yIAxisEndPoint, xJAxisEndPoint, yJAxisEndPoint)

Parameters

objectHandle HANDLE 図形のハンドル
xOriginPoint REAL 原点のX座標
yOriginPoint REAL 原点のY座標
xIAxisEndPoint REAL I軸終点のX座標
yIAxisEndPoint REAL I軸終点のY座標
xJAxisEndPoint REAL J軸終点のX座標
yJAxisEndPoint REAL J軸終点のY座標

Example

GetFillPoints(objectHandle, xOrigin, yOrigin, xIAxis, yIAxis, xJAxis, yJAxis);

Version

利用可能バージョン: VectorWorks10.0