VS:ColorIndexToRGB/ja

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

カラーパレットの色番号から各色の成分を取り出します。値の範囲は0から65535までです。

PROCEDURE ColorIndexToRGB(
color :INTEGER;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.ColorIndexToRGB(color):
    return (red, green, blue)

Parameters

color INTEGER 色番号
red LONGINT 赤の成分
green LONGINT 緑の成分
blue LONGINT 青の成分

Example

ColorIndexToRGB(45,r,g,b);
{returns the color value components of the color at position 45}

Version

利用可能バージョン: MiniCAD6.0