VS:ClosePoly

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedures ClosePoly set the polygon creation mode for polygon objects created in VectorScript to closed. To turn this mode off, use Procedure OpenPoly; the two modes used in conjunction will act as a toggle for the feature.

PROCEDURE ClosePoly;
def vs.ClosePoly():
    return None

Example

VectorScript

ClosePoly;
Poly(0,0,1,1,1,-1);
{creates a closed 3 sided polygon}

Python

vs.ClosePoly()
vs.Poly(0,0,1,1,1,-1)
#{creates a closed 3 sided polygon}

Version

Availability: from All Versions

See Also

AddPoint ArcTo BeginPoly ClosePoly
CurveThrough CurveTo DelVertex EndPoly
GetHole GetNumHoles GetPolyPt GetPolylineVertex
GetVertNum GetVertexVisibility InsertVertex OpenPoly
Poly SetPolyPt SetPolylineVertex SetVertexVisibility
Smooth

[[VS:AddPoint|AddPoint]] [[VS:ArcTo|ArcTo]] [[VS:BeginPoly|BeginPoly]] [[VS:ClosePoly|ClosePoly]] [[VS:CurveThrough|CurveThrough]] [[VS:CurveTo|CurveTo]] [[VS:DelVertex|DelVertex]] [[VS:EndPoly|EndPoly]] [[VS:GetHole|GetHole]] [[VS:GetNumHoles|GetNumHoles]] [[VS:GetPolylineVertex|GetPolylineVertex]] [[VS:GetPolyPt|GetPolyPt]] [[VS:GetVertexVisibility|GetVertexVisibility]] [[VS:GetVertNum|GetVertNum]] [[VS:InsertVertex|InsertVertex]] [[VS:OpenPoly|OpenPoly]] [[VS:Poly|Poly]] [[VS:SetPolylineVertex|SetPolylineVertex]] [[VS:SetPolyPt|SetPolyPt]] [[VS:SetVertexVisibility|SetVertexVisibility]] [[VS:Smooth|Smooth]]