VCOM:VectorWorks:Workspaces:IWorkspaceMenuChunk::GetMenuInfoAtIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceMenuChunk

Gets the menu item info at the given index.

virtual VCOMError VCOM_CALLTYPE GetMenuInfoAtIndex(
Sint16 inMenuItemIndex,
TXString& outMenuItemDisplayText,
bool& outHasShortcutKey,
char& outShortcutKey,
Uint32& outShortcutKeyModifiers) = 0;

Parameters

inMenuItemIndex Sint16 the index of the menu item's info to retrieve.
outMenuItemDisplayText TXString& no info
outHasShortcutKey bool& will be true if this menu item has shortcut key information to retrieve.
outShortcutKey char& will contain the short cut key used for the menu item if outHasShortcutKey is true. Otherwise the value is undefined.
outShortcutKeyModifiers Uint32& will contain the short cut key modifiers used for the menu item if outHasShortcutKey is true. Otherwise the value is undefined.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.