VCOM:VectorWorks:Workspaces:IWorkspaceMenu::GetMenuItemAtIndex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaceMenu

Gets menu item at the given index.

virtual VCOMError VCOM_CALLTYPE GetMenuItemAtIndex(
Sint16 inMenuItemIndex,
IVWUnknown** outMenuItem,
EWorkspaceMenuChunkType& outChunkType) = 0;

Parameters

inMenuItemIndex Sint16 the index of the menu item to retrieve.
outChunkType IVWUnknown** on output, if successful, a pointer to a menu item pointer or menu chunk pointer.
outChunkType EWorkspaceMenuChunkType& no info

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.