VCOM:VectorWorks:UI:IProgressDialog::SetMeterText

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IProgressDialog

Set meter text for the progress dialog.

virtual VCOMError VCOM_CALLTYPE SetMeterText(
const TXString& szMeterText) = 0;

Parameters

szMeterText const TXString& The new text.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.