VCOM:VectorWorks:Scripting:IScriptEditor::Display

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::VectorScript

Member of VCOM:VectorWorks:Scripting:IScriptEditor

The VectorScript Editor interface is responsible for displaying the VectorScript Editor dialog where VectorScript developers can edit, compile, and save their scripts.

virtual VCOMErrorVCOM_CALLTYPE Display(
TVSEditorData& editorData,
ViewRect& windowBounds,
bool& dismissedWithOK) = 0;

Parameters

editorData TVSEditorData& a structure that contains the necessary data to display the VectorScript. If the script is editable, the editorData will contain the script after the changes have been made.
windowBounds ViewRect& the bounds that the VectorScript Editor dialog window will be in.
dismissedWithOK bool& a bool that denotes whether or not the end-user dismissed the dialog by pressing the OK button.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.