VCOM:VectorWorks:Scripting:IPythonWrapper::RunText

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonWrapper

Execute a text representing python script into the run-time. Note that this execution will modify the run-time, so consecutive calls to RunText will use the same data (variables, values, and so on.

virtual voidVCOM_CALLTYPE RunText(
const char* pythonCode) = 0;

Parameters

pythonCode const char* The python script code.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014