VCOM:VectorWorks:Scripting:IPythonWrapper

From Vectorworks Developer
Revision as of 15:46, 19 September 2013 by Root (talk | contribs)
Jump to navigation Jump to search

Description

namespace VectorWorks::Scripting

This interface is a representation of a python run-time. You can use this interface to create a run-time, set it up, and execute scripts.

Note that executing scripts consecutively in an run-time environment will let all defined variable remain after each script execution.

Interface

...put the class definition, including the UUID, here...

Members

AddPath
LoadModule
CompileText
RunText
Call
GetCallResult

Remarks

There is predefined type for smart VCOM pointer VCOMPtr to IPythonWrapper interface:

typedef VCOMPtr<IPythonWrapper>  IPythonWrapperPtr;

Use the following interface to capture the logging from the script execution:

class DYNAMIC_ATTRIBUTE IPythonLogger
{
public:
	virtual ~IPythonLogger() {}

	virtual void VCOM_CALLTYPE LogStdOut(const char* msg) = 0;
	virtual void VCOM_CALLTYPE LogStdErr(const char* msg) = 0;
};

Version

Available from: Vectorworks 2014

See Also

VCOM:VCOMPtr

[[VCOM:VCOMPtr]]