VCOM:VectorWorks:ISDK::WSOpen

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Open a workspace file for reading or writing.

@param inWorkspaceFileToWrite is a reference to the file that VectorWorks will create to store and or provide Workspace data.

@param outWorkspaceReference will be a reference to an open Workspace file if the operation was successful.

@return true if the operation was successful.

virtual bool WSOpen(
const TXString& inWorkspaceFileToOpen,
long inFilePermissions,
long* outWorkspaceReference)

Parameters

constTXString& inWorkspaceFileToOpen No information available.
long inFilePermissions No information available.
long* outWorkspaceReference No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009