VCOM:VectorWorks:ISDK::WSAddMenuItem

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Adds a new menu item definition to the master list of menu items in the referrenced workspace.


@param inWorkspaceReference is a reference to the XML Workspace file..

@param inMenuItemIdentifier the menu item that we are adding to the workspace.

@param inMenuItemsUniversalName the name of the menu item that we are adding to the workspace.

@param inShortcutKey the shortcut key to activate this menu item.

@param inShortcutKeyModifiers the modifier keys that are used in combination with the shortcut key to activate this menu item.

@param inSubMenuIdentifier the submenu that hangs off of this menu item.

@return true if the operation was successful.

virtual bool WSAddMenuItem(
long inWorkspaceReference,
const TXString& inMenuIdentifier,
const TXString& inMenuItemsUniversalName,
char inShortcutKey,
Uint32 inShortcutKeyModifiers,
const TXString& inSubMenuIdentifier)

Parameters

long inWorkspaceReference No information available.
constTXString& inMenuIdentifier No information available.
constTXString& inMenuItemsUniversalName No information available.
char inShortcutKey No information available.
Uint32 inShortcutKeyModifiers No information available.
constTXString& inSubMenuIdentifier No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009