VCOM:VectorWorks:ISDK::WSAddMenu

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Adds a new workspace to the referenced workspace file.

@param inWorkspaceReference is a reference to the XML Workspace file..

@param inMenuIdentifier the menu that we are adding to the workspace.

@param inMenuName the name of the menu that we are adding.

@return true if the operation was successful.

virtual bool WSAddMenu(
long inWorkspaceReference,
const TXString& inMenuIdentifier,
const TXString& inMenuName)

Parameters

long inWorkspaceReference No information available.
constTXString& inMenuIdentifier No information available.
constTXString& inMenuName No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009